Child pages
  • SiteGrinder 3 Requirements
Skip to end of metadata
Go to start of metadata

Photoshop Requirements

In terms of hardware and OS, if you can run Photoshop, you can run SiteGrinder 3.

In terms of software:

  • Microsoft Windows: Photoshop 7, CS, CS2, CS3 and CS4; Photoshop Elements 3, 4, 5, 6, 7, and 8
  • Mac OS X:  Photoshop CS3 and CS4; Photoshop Elements 6, 7, and 8

Support for Photoshop CS2 Mac and earlier versions is being worked on.

Server Requirements

SiteGrinder can build three types of sites: No CMS, Local Only CMS,  and interactive PHP CMS. (More server types like ASP may be supported in the future.)

Static "No CMS" HTML (just like SiteGrinder 2 basically)

There are no extraordinary requirements. These two requirements are very common:

  • FTP access
  • FTP directory creation.
Local-Only CMS
  • The advanced SiteGrinder site management features will only run locally on your computer.
  • SiteGrinder Blog feature not supported
  • Dynamic -xmedia importers not supported.

SiteGrinder PHP CMS

  • PHP 5 with standard extensions
  • ...and the cURL extension installed for certain xmedia importers (like Google docs)
  • ...and file_uploads ON
  • FTP access
  • FTP directory creation

If you wish to test your server to see whether or not it will be able to support the SiteGrinder CMS, place the checkserver.php file on your server and view that page.  You can download the file here: http://www.medialab.com/sitegrinder3/resources/checkserver.zip

ECommerce Requirements

FoxyCart- At this time there is only one ecommerce module supported. Users wishing to use SiteGrinder's integrated ecommerce support need their own FoxyCart subscription as well as a payment gateway.

See the Commerce Reference and FoxyCart Reference for more information.